8x8 Admin Console portal not loading

Performance Issue

8x8 Admin Console portal not loading

Status: closed
Start:
End:
Duration: 32 minutes
Affected Components:
Service portals Service portals Service portals Americas EMEA APAC Admin Console (AC) Admin Console (AC) Admin Console (AC)
Update

8x8 is investigating reports of the 8x8 Admin Console interface failing to load. The proper teams are investigating and we'll provide updates as they become available. 

Resolved

8x8 has resolved the issue with Admin Console admins. The root cause is being investigated and we apologize for the inconvenience.